Support de Ruby et Rails dans Netbeans 7.2

Contexte

Ruby et Rails ne sont officiellement plus supportés depuis la version 7.0 de l'IDE.

Installation de Netbeans 7.2

Installation d'une version disponible sur le site, par exemple celle qui intègre le support PHP.

~$ wget http://download.netbeans.org/netbeans/7.2.1/final/bundles/netbeans-7.2.1-ml-php-linux.sh
~$ chmod +x netbeans-7.2.1-ml-php-linux.sh
~$ ./netbeans-7.2.1-ml-php-linux.sh
~$ echo "export PATH=\"~/path_to_netbeans-7.2.1/bin:\$PATH\"" >> ~/.bashrc && . ~/.bashrc

Plus de détails sur l'installation de Netbeans sont disponibles ici.

Support Ruby et Rails

Le plugin maintenu par la communauté est disponible via l'ajout d'une nouvelle source.

~$ netbeans

> Menu Tools > Plugins > Settings > Add
Name : Ruby
URL : https://blogs.oracle.com/geertjan/resource/nb-72-community-ruby.xml

> Menu Tools > Plugins > Available Plugins
Cocher "Ruby and Rails" puis cliquer sur "Install"
Suivre la procédure jusqu'au redémarrage de Netbeans

Plus de détails sur le support Ruby et Rails sous Netbeans 7.2 sont disponibles ici. Une solution pour Netbeans 7.1 était disponible .

Enjoy

Création d'un projet Ruby ou Rails.

> Menu File > New project > Ruby

Dernière mise à jour le 09/02/2013